Skip to main content

Redistribution Between any Pair of Routing Protocols

 Redistribution Between Any Pair of Routing Protocols

Redistribution allows routes from one routing protocol to be injected into another. However, because different routing protocols use different metrics (e.g., RIP uses hop count, OSPF uses cost), appropriate metric settings must be configured during redistribution to ensure proper route propagation and avoid issues like routing loops.

Key Considerations:

  • Redistributing Metrics:
    • EIGRP uses a composite metric (bandwidth, delay, reliability, load, MTU), while OSPF uses cost (based on bandwidth), and RIP uses hop count. When redistributing between these protocols, ensure the metrics are compatible.
    • When redistributing from a protocol like OSPF to RIP, a manual metric must be set, typically a low value like 1, to allow routes to propagate across the entire RIP domain (15-hop limit).

Redistribute OSPF into RIP

  • Metric Consideration: OSPF uses cost, while RIP uses hop count. To ensure proper route propagation, set an appropriate metric for routes being redistributed from OSPF to RIP.
    • Technical Tip: Use a low metric (e.g., 1) to allow maximum hop propagation in RIP but avoid too low a value to prevent routing loops in networks with multiple redistribution points.

Example:

router rip

redistribute ospf 1 metric 1

Redistribute EIGRP into RIP

  • EIGRP Redistribution: EIGRP requires five metric components (bandwidth, delay, reliability, load, MTU), though MTU is not used in actual calculations but is still required.
    • Technical Tip: When redistributing into EIGRP, manually configure the metric. The exception is redistributing connected routes or static routes where EIGRP can automatically calculate the metric.

Example:

router eigrp 1

redistribute rip metric 10000 100 255 1 1500

  • Precedence of Routes: A redistributed static route can take precedence over a summary route in EIGRP due to a lower AD (Administrative Distance).

Redistribute OSPF in EIGRP

  • Setting Metrics in EIGRP: When redistributing OSPF into EIGRP, the metric must be set manually. The default-metric command simplifies this by applying a default metric to all redistributed routes.
    • Technical Tip: To see the metric components of an interface, use the show interface command.

Example:

router eigrp 1

default-metric 50000 5 255 2 1400

redistribute ospf 1

Redistribute RIPv2 and OSPF

  • OSPF Redistribution: OSPF uses the subnets keyword to include subnetted routes during redistribution. Without this, only classful routes will be redistributed.
    • Technical Tip: OSPF assigns a default cost of 20 when redistributing IGP routes and 1 for BGP routes. Adjust the default-metric if needed.

Example:

router ospf 1

redistribute rip metric 100 subnets

Miscellaneous Redistribute Commands

  • Route Maps for Tagging and Filtering: Use route maps with the set tag or match source-protocol commands to manage route redistribution.
    • Technical Tip: You can prevent routing loops by using administrative distance tags to recognize the protocol from which a route originated (EIGRP = 90, OSPF = 110, RIP = 120).

Example:

route-map filter-in deny 10

match tag 111

router ospf 1

distribute-list route-map filter-in in

Redistribute into OSPF

  • OSPF External Routes: When redistributing routes into OSPF, the routes are classified as either E1 (Type 1) or E2 (Type 2). Type 1 routes include internal costs, while Type 2 routes do not.
    • Technical Tip: Use E1 for load balancing based on internal metrics. E2 is the default and maintains the external metric without adding internal costs.

Example:

router ospf 1

redistribute eigrp 1 metric 20 metric-type 1

Redistributing in BGP

  • BGP Redistribution: BGP prefers routes learned from other routing protocols and retains their metric (MED). Be cautious when redistributing into BGP to prevent injecting a large number of routes into the IGP.
    • Technical Tip: Avoid redistributing BGP routes into IGPs to prevent instability due to a large number of Internet routes being injected.

Example:

router bgp 100

redistribute ospf 1 match internal external

  • Effect of Auto-Summary: When redistributing with auto-summary enabled, only classful routes will be redistributed. Disable auto-summary to redistribute subnets as well.

Summary of Technical Tips:

  • Always configure appropriate metrics when redistributing between different protocols to avoid routing issues.
  • Use the subnets keyword when redistributing into OSPF to ensure subnets are included.
  • Apply route maps to control which routes are redistributed and prevent routing loops.
  • Use the metric-type command in OSPF to distinguish between E1 and E2 routes based on network requirements.
  • Avoid redistributing BGP into IGPs unless absolutely necessary to prevent instability caused by large routing tables.

Comments

Popular posts from this blog

How to import Putty Saved Connections to mRemoteNG

Just started using mRemoteNG and its being very cool to connect to different remote connection with different protocols e.g Window Remote Desktop, VNC to Linux, SSH, HTTP connection etc. from a single application. As new user I configured some remote desktop connection which was quite easy to figure out. But when I wanted to add SSH connections, it came in my mind to import all of the saved connections in the putty. But I couldn't figure it out how can it be done, though it was quite easy and here are the steps. Open your mRemoteNG Create a folder if you want segregation of multiple networks Create a new connection Enter the IP address of remote server under connection in Config pane Under the config pane, select protocol " SSH version 2 ".  Once you select protocol to SSH version 2 you are given option to import putty sessions, as shown in the snap below. In the above snap, I have imported CSR-AWS session from my saved sessions in Putty.

AS Path Prepending: Controlling Inbound Traffic in BGP

AS Path Prepending is a BGP feature used to make a specific path appear less preferred by artificially lengthening the AS path. This is done by adding your AS number multiple times to the AS path. It is a common method to influence inbound traffic from external networks. Longer AS Path = Less preferred route . Example Scenario : You have two ISPs: ISP1 (through CE1) and ISP2 (through CE2). You want inbound traffic from the internet to prefer ISP1 over ISP2. Network Topology : CE1 (connected to ISP1): 10.0.1.1/30 CE2 (connected to ISP2): 10.0.2.1/30 iBGP Router (Internal) connected to both CE1 (10.0.1.2/30) and CE2 (10.0.2.2/30). Configuration on CE2 (AS Path Prepending to Make ISP2 Less Preferred) : Create a route map to prepend your AS path multiple times for CE2: route-map PREPEND_AS permit 10 set as-path prepend 65001 65001 65001 Apply this route map to the neighbor in the BGP configuration for CE2: router bgp 65001 neighbor 10.0.2.1 remote-as 65002 neighbor 10.0.2.1 ro...

Authoritative DNS Servers Delegation and Internal DNS Explained

DNS (Domain Name System) plays a critical role in how users and systems find resources on the internet or within internal networks. Whether it's managing an internal domain in an enterprise or delegating parts of a domain for traffic distribution, DNS setups vary widely depending on needs. In this blog post, we’ll break down the different types of DNS setups, including authoritative DNS servers, DNS delegation, and how internal DNS functions within organizations. 1. Authoritative DNS Server An Authoritative DNS server is the final source of truth for a specific domain. When someone queries a domain (e.g., example.com ), the authoritative DNS server for that domain holds the DNS records (A records, CNAME, MX, etc.) and responds with the corresponding IP address. Key Points: Who can host it? Authoritative DNS servers are often hosted by domain registrars (e.g., GoDaddy, Namecheap) or cloud DNS providers (e.g., AWS Route 53, Cloudflare). However, organizations can also host their ...