Skip to main content

System Management - Key concepts

 Device Management

Console and VTY

  • Console and VTY provide access to the device CLI for configuration and troubleshooting.
    • Console is used for local access.
    • VTY allows remote access via Telnet or SSH.
    • TCP Keepalives: Use service tcp-keepalives-in to avoid dead Telnet or SSH sessions occupying VTY lines.

Router1(config)#service tcp-keepalives-in

Technical Tip: To prevent being locked out of a router due to exhausted VTY lines, configure an access list restricting VTY access.

access-list 9 permit 172.25.1.1

line vty 0 4

 access-class 9 in

  • Source Interface for Telnet: Set the router to use a specific IP for outgoing Telnet connections using:

ip telnet source-interface loopback0

SSH and SCP

  • SSH: Use Secure Shell (SSH) to securely access the device. Configure SSH with RSA keys.

ip domain-name example.com

crypto key generate rsa modulus 1024

  • SCP (Secure Copy Protocol): SCP can be used to securely transfer files between network devices.

Technical Tip: Ensure SSH and SCP are properly configured on the device with password-based or key-based authentication for security.

RESTCONF and NETCONF

  • RESTCONF and NETCONF are modern APIs for managing network devices.
    • NETCONF uses XML for communication.
    • RESTCONF uses HTTP-based methods for managing network configurations.

Technical Tip: Use NETCONF for configuration and state monitoring when automating with tools like Ansible or Python scripts. RESTCONF is more HTTP-friendly and can integrate with web applications.

Using Telnet

  • Telnet: Insecure and should be replaced with SSH. However, for legacy systems, manage sessions by adjusting the inactivity timer.

service tcp-keepalives-in

exec-timeout 180

Technical Tip: Disable the default hostname resolution to avoid unnecessary Telnet connections on typos.

Router1(config)#line vty 0 4

Router1(config-line)#transport preferred none

Using ARP

  • ARP: Use Address Resolution Protocol to map IP addresses to MAC addresses. Commands like show ip arp help troubleshoot address mappings.

Technical Tip: Clear ARP cache when troubleshooting inconsistent IP-to-MAC mappings:

clear arp-cache

Using CDP

  • CDP (Cisco Discovery Protocol): Use show cdp neighbors detail for topology discovery and neighbor information.

Technical Tip: Reduce CDP timer settings for quicker updates in dynamic environments:

cdp timer 30

cdp holdtime 120

Using IP Host

  • IP Host: Configure static DNS-like mappings between hostnames and IP addresses using the ip host command.

Technical Tip: Use ip host for quick telnet or SSH access to devices:

ip host Router1 192.168.1.1

Reload Commands

  • Schedule router reloads for maintenance or upgrades:

reload in 20

reload at 14:00 Feb 15

Technical Tip: Always use the show reload command to verify scheduled reloads and use reload cancel if needed.

SNMP

SNMP Overview

  • SNMP (Simple Network Management Protocol) is used for monitoring and managing network devices.
    • SNMP Manager: The network management system (NMS) that collects data from network devices.
    • SNMP Agent: The software on the device that responds to SNMP queries.

SNMP Versions

  • SNMPv1/v2c: Uses community strings for authentication (less secure).
  • SNMPv3: Adds security with authentication and encryption, providing:
    • Message Integrity: Ensures the message was not tampered with.
    • Authentication: Verifies the source of the message.
    • Encryption: Secures the contents of the message.

Technical Tip: Always prefer SNMPv3 for better security, using authentication and encryption:

snmp-server user user1 group1 v3 auth md5 password123 priv des password123

SNMP Configuration

  • Basic SNMP configuration example:

snmp-server community public ro 33

snmp-server location DataCenter

snmp-server enable traps bgp hsrp

snmp-server host 192.168.1.100 public

Technical Tip: Use access-lists to restrict SNMP queries to specific IP ranges:

access-list 33 permit 192.168.1.0 0.0.0.255

Traps and Informs

  • Traps: Unreliable notifications sent to the SNMP manager.
  • Informs: Reliable notifications requiring an acknowledgment from the SNMP manager.

Technical Tip: Use traps for routine monitoring, but consider informs for critical events where confirmation is essential.

Logging

Logging (Local Logging, Syslog, Debugs)

  • Local Logging: Logs messages to the internal buffer.

logging buffered 8192

Technical Tip: Limit log buffer size to avoid memory exhaustion on the device.

  • Syslog: Sends log messages to an external Syslog server.

logging host 192.168.1.100

logging trap debugging

  • Debugging: Use debug commands for real-time troubleshooting, but be cautious as they may affect performance.

debug ip packet

undebug all  # Turn off debugging

Technical Tip: Always use conditional debugging to limit the scope of debug output to specific interfaces or protocols:

debug interface Loopback0

Timestamps

  • Timestamps: Use timestamps to add time information to log messages, aiding in event correlation.

service timestamps log datetime msec localtime show-timezone

Technical Troubleshooting Tips

  • Always use show commands to verify configurations:

show running-config

show snmp community

show log

  • When logging messages, ensure correct severity levels are configured for better visibility:

logging trap errors

  • For SNMP issues, verify the SNMP community strings and ACLs blocking SNMP traffic using:

show snmp community

show access-lists

Comments

Popular posts from this blog

Basic MPLS BGP and L3VPN Lab Setup

In this lab, we’ve set up a basic MPLS, BGP, and L3VPN environment, which is a great foundation for understanding how service providers build scalable networks. The lab uses the EVE-NG simulator along with Router IOS C7200-ADVENTERPRISEK9-M, Version 15.2(4)M8 to emulate a realistic MPLS environment. Below is a summary of the key components and roles of each router in the lab. MPLS Core Routers : The MPLS core consists of the routers responsible for label switching and forwarding customer traffic through the network: PE1 (Provider Edge 1) : Connects customer networks to the MPLS core and handles both MPLS and BGP routing. It also hosts VRF (Virtual Routing and Forwarding) instances for customers. PE2 (Provider Edge 2) : Functions similarly to PE1, connecting another customer network to the MPLS core. P1 (Core Router 1) and P2 (Core Router 2) : These routers serve as MPLS core routers and handle label switching but do not store or process customer routes directly. They simply f

OSPF Adjacency Stuck in EXSTART on Cisco IOS XR – Issue and Solution

In a recent lab setup using Cisco IOS XR on EVE-NG, I faced a common but frustrating issue with OSPF adjacencies getting stuck in the EXSTART state. After spending considerable time troubleshooting interface MTUs and configurations, I discovered that the root cause was related to the virtual network interface type being used. This post outlines the issue, troubleshooting steps, and the eventual solution that got everything working. Issue: While configuring OSPF between two routers running Cisco IOS XR in my lab, OSPF adjacencies were getting stuck in the EXSTART state. I verified that interface configurations, MTU settings, and OSPF parameters were correct, but the problem persisted. I tried adjusting the MTU size, using the mtu-ignore command, and even checked for ACLs, but nothing seemed to resolve the issue. Troubleshooting Steps: MTU Settings: I started by verifying that both sides of the OSPF adjacency had matching MTUs. I used the default MTU and even tried different values wit

How to Properly Clone an EVE-NG Lab with Configurations

Cloning labs in EVE-NG is a great way to duplicate setups and expand or experiment on a new copy without affecting the original lab. However, if not done correctly, the cloned lab may only copy the topology without configurations. In this guide, I’ll show you how to properly clone a lab in EVE-NG with all configurations using the EVE-NG GUI . Follow these steps to ensure that both the topology and router configurations are retained when cloning your lab. Steps to Clone an EVE-NG Lab with Configurations Save Running Configuration on All Devices In your original lab, make sure all devices have their configurations saved to NVRAM. Go into the CLI of each router and run the command: copy running-config startup-config Export All Configurations (CFGs) On the left sidebar in the EVE-NG Web UI , click on the "More Actions" option. Then select "Export all CFGs" . This step exports the configurations of all devices in the lab. Shutdown All Devices After exporting the confi